pantz.org banner
Cisco T1 configuration
Posted on 02-22-2003 01:13:00 UTC | Updated on 02-22-2003 01:13:00 UTC
Section: /software/ios/ | Permanent Link

This is an example of a T1 configuration on a Cisco 2500 with IOS 10.3 (yes I know the router is old as dirt). The router does not have a csu/dsu built in so you will need one to hook the line from the phone company up to. Ask your Internet provider for the line settings of the csu/dsu like framing type (ex. b8zs) and line coding type (ex. ESF).Also you need to see what channel your starting on. If your PBX is going to use 12 of the 24 channels then your csu/dsu needs to start on channel 13. If your using a full T1 then you start a channel 1.

Your Internet provider should also be able to provide the encapsulation type (ex. IETF) and lmi-type (ex. ansi). They will give you a block of IP addresses and tell you what is the gateway for your router. For my example its the serial0 line below. For the internal gateway for your network you will be using another interface. The example uses Ethernet0. The first IP on your block of IP's is usually binded to this interface. This is the gateway for the computers on your network.

This example of course has fake IP's so you'll need to subsitute your own. The config below is output from the "show config" command at a router prompt. But they are also the commands you need to do when you are enabled and in config terminal mode. If anyone wants a better description of this mail me (see the "about" section for the e-mail address) and maby I'll put more detail here.


version 10.3

!
hostname blah.test.org
!
enable secret 5 (#$30u34(#(%)@_$%*#!_BIEWQBMX
enable password passwordhere
!
ip subnet-zero
!
interface Ethernet0
 ip address 5.5.5.5 255.255.255.128
 no ip directed-broadcast
!
interface Serial0
 description Gateway to Internet provider
 ip address 4.4.4.4 255.255.255.252
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no ip route-cache
 bandwidth 1536
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 4.4.4.3
banner login ^C
-=Welcome to the main gateway=-
^C
!
line con 0
 password passwordhere
 login
line aux 0
 transport input all
line vty 0 4
 password passwordhere
 login
!
end

Reddit!

Related stories


RSS Feed RSS feed logo

About


3com

3ware

alsa

alsactl

alsamixer

amd

android

apache

areca

arm

ati

auditd

awk

badblocks

bash

bind

bios

bonnie

cable

carp

cat5

cdrom

cellphone

centos

chart

chrome

chromebook

cifs

cisco

cloudera

comcast

commands

comodo

compiz-fusion

corsair

cpufreq

cpufrequtils

cpuspeed

cron

crontab

crossover

cu

cups

cvs

database

dbus

dd

dd_rescue

ddclient

debian

decimal

dhclient

dhcp

diagnostic

diskexplorer

disks

dkim

dns

dos

dovecot

drac

dsniff

dvdauthor

e-mail

echo

editor

emerald

ethernet

expect

ext3

ext4

fat32

fedora

fetchmail

fiber

filesystems

firefox

firewall

flac

flexlm

floppy

flowtools

fonts

format

freebsd

ftp

gdm

gmail

gnome

google

greasemonkey

greylisting

growisofs

grub

hacking

hadoop

harddrive

hba

hex

hfsc

html

html5

http

https

hulu

idl

ie

ilo

intel

ios

iperf

ipmi

iptables

ipv6

irix

javascript

kde

kernel

kickstart

kmail

kprinter

krecord

kubuntu

kvm

lame

ldap

linux

logfile

lp

lpq

lpr

maradns

matlab

memory

mencoder

mhdd

mkinitrd

mkisofs

moinmoin

motherboard

mouse

movemail

mplayer

multitail

mutt

myodbc

mysql

mythtv

nagios

nameserver

netflix

netflow

nginx

nic

ntfs

ntp

nvidia

odbc

openbsd

openntpd

openoffice

openssh

openssl

openvpn

opteron

parted

partimage

patch

perl

pf

pfflowd

pfsync

photorec

php

pop3

pop3s

ports

postfix

power

procmail

proftpd

proxy

pulseaudio

putty

pxe

python

qemu

r-studio

raid

recovery

redhat

router

rpc

rsync

ruby

saltstack

samba

schedule

screen

scsi

seagate

seatools

sed

sendmail

sgi

shell

siw

smtp

snort

solaris

soundcard

sox

spam

spamd

spf

spotify

sql

sqlite

squid

srs

ssh

ssh.com

ssl

su

subnet

subversion

sudo

sun

supermicro

switches

symbols

syslinux

syslog

systemd

systemrescuecd

t1

tcpip

tcpwrappers

telnet

terminal

testdisk

tftp

thttpd

thunderbird

timezone

ting

tls

tools

tr

trac

tuning

tunnel

ubuntu

unbound

vi

vpn

wget

wiki

windows

windowsxp

wireless

wpa_supplicant

x

xauth

xfree86

xfs

xinearama

xmms

youtube

zdump

zeromq

zic

zlib